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Substructuring

Introduction

This tutorial was completed using ANSY'S 7.0 The purpose of the tutorial is to show the how to use
substructuring in ANSYS. Substructuring is a procedure that condenses a group of finite elements into one
super-element. This reduces the required computation time and also allows the solution of very large problems.

A simple example will be demonstrated to explain the steps required, however, please note that this model is
not one which requires the use of substructuring. The example involves a block of wood (E =10 GPa v =0.29)
connected to a block of silicone (E = 2.5 MPa, v = 0.41) which is rigidly attached to the ground. A force will be
applied to the structure as shown in the following figure. For this example, substructuring will be used for the
wood block.

—

The use of substructuring in ANSYS is a three stage process:

1. Generation Pass
Generate the super-element by condensing several elements together. Select the degrees of freedom to
save (master DOFs) and to discard (slave DOFs). Apply loads to the super-element

2. Use Pass
Create the full model including the super-element created in the generation pass. Apply remaining loads
to the model. The solution will consist of the reduced solution tor the super-element and the complete
solution for the non-superelements.

3. Expansion Pass
Expand the reduced solution to obtain the solution at all DOFs for the super-element.

Note that a this method is a bottom-up substructuring (each super-element is created separately and then
assembled in the Use Pass). Top-down substructuring is also possible in ANSYS (the entire model is built, then
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super-clement are created by selecting the appropriate elements). This method is suitable for smaller models and
has the advantage that the results for multiple super-elements can be assembled in postprocessing.

Expansion Pass: Creating the Super-element

Preprocessing: Defining the Problem

1. Give Generation Pass a Jobname
Utility Menu > File > Change Jobname ...

Enter '"GEN' for the jobname

2. Open preprocessor menu

ANSYS Main Menu > Preprocessor
/PREP7

3. Create geometry of the super-element

Preprocessor > Modeling > Create > Areas > Rectangle > By 2 Corners
BLC4, XCORNER, YCORNER, WIDTH, HEIGHT

Create a rectangle with the dimensions (all units in mm):

XCORNER (WP X)
YCORNER (WP Y)
Width = 100
Height = 100

0
40

4. Define the Type of Element
Preprocessor > Element Type > Add/Edit/Delete...

For this problem we will use PLANE42 (2D structural solid). This element has 4 nodes, each with
2 degrees of freedom (translation along the X and Y axes).

5. Define Element Material Properties
Preprocessor > Material Props > Material Models > Structural > Linear > Elastic > Isotropic

In the window that appears, enter the following geometric properties for wood:
i. Young's modulus EX: 10000 (MPa)
ii. Poisson's Ratio PRXY: 0.29

6. Define Mesh Size
Preprocessor > Meshing > Size Cntrls > Manual Size > Areas > All Areas ...

For this example we will use an element edge length of 10mm.

7. Mesh the block

Preprocessor > Meshing > Mesh > Areas > Free > click 'Pick All'
AMESH, 1
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Solution Phase: Assigning Loads and Solving

1. Define Analysis Type

Solution > Analysis Type > New Analysis > Substructuring
ANTYPE, SUBST

2. Select Substructuring Analysis Options
It is necessary to define the substructuring analysis options
o Select Solution > Analysis Type > Analysis Options

o The following window will appear. Ensure that the options are filled in as shown.

m Substructuring Analysis = il
[SEOPT] Substructuring Analysis Options
Sename Name to be assigned to - GEN

- superelement matrig fie

SEMATR Matrices to be generated |5tﬁr-,e55 ‘:|
SEPR Items to be printed [No printout =l
SESST Save space for [S]? ™ No

([5] & the stress stiffness matrix)
EXPMTH Expansion pass method | Backsubstitution =l
[LUMPM] Use umped mass approx? (s

(if mass matrix s to be generated)

[EQSLY] Equation sohver IFn:untaI sohver j

oK Cancel | Hep |

» Sename (the name of the super-element matrix file) will default to the jobname.
= In this case, the stiffness matrix is to be generated.
= With the option SEPR, the stiffness matrix or load matrix can be printed to the output
window if desired.
3. Select Master Degrees of Freedom

Master DOFs must be defined at the interface between the super-element and other elements in addition
to points where loads/constraints are applied.

o Select Solution > Master DOFs > User Selected > Define

o Select the Master DOF as shown in the following figure.
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nAHS"l"S Graphics eplot M=] B

1
ELEMENTZ

o In the window that appears, set the 1st degree of freedom to A11 DOF

[H]1 Define User—Selected Master DOFs
Labl 1st degree of freedom |A1l DOF -
Lah2-6 Additional DOFs [TF3

Uy

0K | Apply Cancel I Help

4. Apply Loads
Solution > Define Loads > Apply > Structural > Force/Moment > On Nodes

Place a load of 5N in the x direction on the top left hand node

The model should now appear as shown in the figure below.
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J\ ANSYS Graphics eplot

1
ELEMENTS

S. Save the database
Utility Menu > File > Save as Jobname.db
SAVE

Save the database to be used again in the expansion pass

6. Solve the System

Solution > Solve > Current LS
SOLVE

Use Pass: Using the Super-element
The Use Pass is where we model the entire model, including the super-elements from the Generation Pass.
Preprocessing: Defining the Problem

1. Clear the existing database
Utility Menu > File > Clear & Start New

2. Give Use Pass a Jobname
Utility Menu > File > Change Jobname ...
FILNAME, USE

Enter '"USE' for the jobname
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10.

Open preprocessor menu

ANSYS Main Menu > Preprocessor
/PREP7

Now we need to bring the Super-element into the model

Define the Super-element Type
Preprocessor > Element Type > Add/Edit/Delete...

Select 'Super-element' (MATRIX50)

Create geometry of the non-superelement (Silicone)

Preprocessor > Modeling > Create > Areas > Rectangle > By 2 Corners
BLC4, XCORNER, YCORNER, WIDTH, HEIGHT

Create a rectangle with the dimensions (all units in mm):

0
0

XCORNER (WP X)
YCORNER (WP Y)
Width = 100
Height = 40

Define the Non-Superelement Type
Preprocessor > Element Type > Add/Edit/Delete...

We will again use PLANE42 (2D structural solid).

Define Element Material Properties
Preprocessor > Material Props > Material Models > Structural > Linear > Elastic > Isotropic

In the window that appears, enter the following geometric properties for silicone:
i. Young's modulus EX: 2.5 (MPa)
ii. Poisson's Ratio PRXY: 0.41

Define Mesh Size
Preprocessor > Meshing > Size Cntrls > Manual Size > Areas > All Areas ...

For this block we will again use an element edge length of 10mm. Note that is is imperative that the
nodes of the non-superelement match up with the super-element MDOFs.

Mesh the block

Preprocessor > Meshing > Mesh > Areas > Free > click 'Pick All'
AMESH, 1

Offset Node Numbering

Since both the super-element and the non-superelement were created independently, they contain
similarly numbered nodes (ie both objects will have node #1 etc.). If we bring in the super-element with
similar node numbers, the nodes will overwrite existing nodes from the non-superelements. Therefore, we
need to offset the super-element nodes
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Determine the number of nodes in the existing model
o Select Utility Menu > Parameters > Get Scalar Data ...
o The following window will appear. Select Model Data, For Selected set as shown.

M Get Scalar Data

s gelected zet

Component =
S

B Gt Data lor Selected Entity Set

Ho. of nodes
Highezt node num

Offset the node numbering

o Select Preprocessor > Modeling > Create > Elements > Super-elements > BY CS Transfer
o Fill in the following window as shown to offset the node numbers and save the file as GEN2

[ Create superdlement by C5 Transfer
[SETRAN] Create Superelerent by C5 Transfer of Existing Superelement

Sermme Name of exgtng superd |GEN
{Le., jobname of existing supersisment matre fie)

KCHTO Coordinate system - In_

-t wihich superelement i b be transferred

NOROT  Fox nodal coond systems? [ Ko - rotate them

NG Mode ncrement W

Fie Mame of new supereem fie IGEN:{ Browse... |
o | _onty | _Cancel | _ree |
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Read in the super-element matrix

o Select Preprocessor > Modeling > Create > Elements > Super-elements > From .SUB File...
o Enter 'GEN2' as the Jobname of the matrix file in the window (shown below)

I Read in Superelement From Matrix File {.SUB)

o Utility Menu > Plot > Replot
11. Couple Node Pairs at Interface of Super-element and Non-Superelements
Select the nodes at the interface

o Select Utility Menu > Select > Entities ...
o The following window will appear. Select Nodes, By Location, Y coordinates, 40 as shown.

M\ Select Entities

Couple the pair nodes at the interface
o Select Preprocessor > Coupling / Ceqn > Coincident Nodes

Re-select all of the nodes
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o Select Utility Menu > Select > Entities ...
o In the window that appears, click 'Nodes > By Num/Pick > From Full > Sele All'

Solution Phase: Assigning Loads and Solving

1. Define Analysis Type

Solution > New Analysis > Static
ANTYPE, 0

2. Apply Constraints
Solution > Define Loads > Apply > Structural > Displacement > On Lines

Fix the bottom line (ie all DOF constrained)
3. Apply super-element load vectors

o Determine the element number of the super-element (Select Utility Menu > PlotCtrls >
Numbering...)

You should find that the super-element is element 41
o Select Solution > Define Loads > Apply > Load Vector > For Super-element

o The following window will appear. Fill it in as shown to apply the super-element load vector.

I Apply superelement Load ¥Yector Ed

o | ety | cancer | | weny

4. Save the database
Utility Menu > File > Save as Jobname.db
SAVE

Save the database to be used again in the expansion pass

5. Solve the System

Solution > Solve > Current LS
SOLVE

General Postprocessing: Viewing the Results
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1. Show the Displacement Contour Plot
General Postproc > Plot Results > Contour Plot > Nodal Solution ... > DOF solution, Translation

USuM
PLNSOL, U, SUM, 0, 1

J\ ANSYS Graphics PLNSOL,U,SUM,0,1

HODAL SOLUTION

ETEP=1
ZUE =1

Note that only the deformation for the non-superelements is plotted. This results agree with what was
found without using substructuring (see figure below).
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J\ AMSYS Graphics PLNSOL,U,5UM,0,1 M=l B3

M
HODAL S0LUTION ——
|

ETEP=1 |
SUE =1

Substructuring Test

Expansion Pass: Expanding the Results within the Super-element
To obtain the solution for all elements within the super-element you will need to perform an expansion pass.
Preprocessing: Defining the Problem

1. Clear the existing database
Utility Menu > File > Clear & Start New

2. Change the Jobname back to Generation pass Jobname
Utility Menu > File > Change Jobname ...
FILNAME, GEN

Enter 'GEN' for the jobname

3. Resume Generation Pass Database
Utility Menu > File > Resume Jobname.db ...
RESUME

Solution Phase: Assigning Loads and Solving

1. Activate Expansion Pass
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o Enter the Solution mode by selecting Main Menu > Solution or by typing /SOLU into the
command line.

o Type '"EXPASS,ON' into the command line to initiate the expansion pass.
2. Enter the Super-element name to be Expanded
o Select Solution > Load STEP OPTS > ExpansionPass > Single Expand >Expand Superelem ...

o The following window will appear. Fill it in as shown to select the super-element.

M Expand Superelement

3. Enter the Super-element name to be Expanded
o Select Solution > Load Step Opts > ExpansionPass > Single Expand > By Load Step...
o The following window will appear. Fill it in as shown to expand the solution.

Il Expand Single Solution by Load Step

4. Solve the System

Solution > Solve > Current LS
SOLVE

General Postprocessing: Viewing the Results

1. Show the Displacement Contour Plot
General Postproc > Plot Results > (-Contour Plot-) Nodal Solution ... > DOF solution, Translation
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USuM
PLNSOL, U, SUM, 0, 1

J\ ANSYS Graphics PLNSOL,U,SUM,0,1 =] B3

NODAL SOLUTION

M
I

Note that only the deformation for the super-elements is plotted (and that the contour intervals have been
modified to begin at 0). This results agree with what was found without using substructuring (see figure
below).
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J\ AMSYS Graphics PLNSOL,U,5UM,0,1 M=l B3

M
HODAL S0LUTION ——
|

ETEP=1 |
SUE =1

Substructuring Test

Command File Mode of Solution

The above example was solved using the Graphical User Interface (or GUI) of ANSYS. This problem has also
been solved using the ANSYS command language interface that you may want to browse. Open the file and
save it to your computer. Now go to 'File > Read input from...' and select the file.
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