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Space Frame Example

Introduction

This tutorial was created using ANSYS 7.0 to solve a simple 3D space frame problem.

Problem Description

The problem to be solved in this example is the analysis of a bicycle frame. The problem to be modeled in this

example is a simple bicycle frame shown in the following figure. The frame is to be built of hollow aluminum
tubing having an outside diameter of 25mm and a wall thickness of 2mm.

Verification

The first step is to simplify the problem. Whenever you are trying out a new analysis type, you need something
(ie analytical solution or experimental data) to compare the results to. This way you can be sure that you've
gotten the correct analysis type, units, scale factors, etc.

The simplified version that will be used for this problem is that of a cantilever beam shown in the following
figure:
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Preprocessing: Defining the Problem
1. Give the Simplified Version a Title (such as 'Verification Model').
Utility Menu > File > Change Title
2. Enter Keypoints

For this simple example, these keypoints are the ends of the beam.

o We are going to define 2 keypoints for the simplified structure as given in the following table
coordinate

keypoint
x|yl z

1 01010
2 |5001 0710

o From the '"ANSYS Main Menu' select:
Preprocessor > Modeling > Create > Keypoints > In Active CS

3. Form Lines
The two keypoints must now be connected to form a bar using a straight line.
o Select: Preprocessor > Modeling> Create > Lines > Lines > Straight Line.
o Pick keypoint #1 (i.e. click on it). It will now be marked by a small yellow box.
o Now pick keypoint #2. A permanent line will appear.
o When you're done, click on 'OK' in the 'Create Straight Line' window.
4. Define the Type of Element

It is now necessary to create elements on this line.
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o From the Preprocessor Menu, select: Element Type > Add/Edit/Delete.

o Click on the 'Add..." button. The following window will appear:

mhhi.u'p of Ebernent Types

Library of Element Types

Elesttotr by rashesrence nusnber

= |

o For this example, we will use the 3D elastic straight pipe element as selected in the above figure.

Select the element shown and click 'OK'. You should see '"Type 1 PIPE16' in the 'Element Types'
window.

o Click on the 'Options..." button in the 'Element Types' dialog box. The following window will
appear:

mPIPEIE element type options : |
Cptions for PIPELG, Element Type Ref. Mo, 1

Temperatures represent K1

Stress int Factors (SIF) from K2

Element id in output K4

Ise aof P¥, PY, PE pressures K5

Mermber Force + moment output K&

(Eyroscopic damping matric K7

(04 | Cancel |

o Click and hold the K6 button (second from the bottom), and select 'Include Output' and click 'OK'.
This gives us extra force and moment output.

o Click on 'Close' in the 'Element Types' dialog box and close the 'Element Type' menu.

5. Define Geometric Properties
We now need to specify geometric properties for our elements:

o In the Preprocessor menu, select Real Constants > Add/Edit/Delete
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o Click Add... and select 'Type 1 PIPE16' (actually it is already selected). Click on 'OK'.

o Enter the following geometric properties:

Outside diameter OD: 25
Wall thickness TKWALL: 2

This defines an outside pipe diameter of 25mm and a wall thickness of 2mm.
o Click on 'OK".
o 'Set 1' now appears in the dialog box. Click on 'Close' in the 'Real Constants' window.
6. Element Material Properties

You then need to specify material properties:
o In the "Preprocessor' menu select Material Props > Material Models...

o Double click Structural > Linear > Elastic and select 'Isotropic' (double click on it)
o Close the 'Define Material Model Behavior' Window.
We are going to give the properties of Aluminum. Enter the following field:

EX 70000
PRXY 0.33

o Set these properties and click on 'OK'.

7. Mesh Size

o In the Preprocessor menu select Meshing > Size Cntrls > ManualSize > Lines > All Lines

o In the size 'SIZE' field, enter the desired element length. For this example we want an element
length of 2cm, therefore, enter '20' (i.e 20mm) and then click 'OK'. Note that we have not yet

meshed the geometry, we have simply defined the element sizes.

(Alternatively, we could enter the number of divisions we want in the line. For an element length of

2cm, we would enter 25 [ie 25 divisions]).

NOTE

It is not necessary to mesh beam elements to obtain the correct solution. However, meshing is done in this
case so that we can obtain results (ie stress, displacement) at intermediate positions on the beam.

8. Mesh

Now the frame can be meshed.

o In the 'Preprocessor' menu select Meshing > Mesh > Lines and click 'Pick All' in the 'Mesh Lines'

Window

9. Saving Your Work

Utility Menu > File > Save as.... Select the name and location where you want to save your file.
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Solution Phase: Assigning Loads and Solving
1. Define Analysis Type
o From the Solution Menu, select 'Analysis Type > New Analysis'.
o Ensure that 'Static' is selected and click 'OK'.
2. Apply Constraints

o In the Solution menu, select Define Loads > Apply > Structural > Displacement > On
Keypoints

o Select the left end of the rod (Keypoint 1) by clicking on it in the Graphics Window and click on
'OK" in the 'Apply U,ROT on KPs' window.

o This location is fixed which means that all translational and rotational degrees of freedom (DOFs)
are constrained. Therefore, select 'All DOF' by clicking on it and enter '0' in the Value field and
click 'OK".

3. Apply Loads
As shown in the diagram, there is a vertically downward load of 100N at the end of the bar
o In the Structural menu, select Force/Moment > on Keypoints.
o Select the second Keypoint (right end of bar) and click 'OK' in the 'Apply F/M' window.
o Click on the 'Direction of force/mom' at the top and select FY.
o Enter a value of -100 in the 'Force/moment value' box and click 'OK".
o The force will appear in the graphics window as a red arrow.

The applied loads and constraints should now appear as shown below.
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4. Solving the System
We now tell ANSYS to find the solution:
o Solution > Solve > Current LS
Postprocessing: Viewing the Results
1. Hand Calculations

Now, since the purpose of this exercise was to verify the results - we need to calculate what we should
find.

Deflection:

a3 (100N SO0y o 3
— : = 0.18mm

P
[t ¥ i E 1 i - i .
: 3EI S(TO000MPenv =m({ L 2. 50y —=(1 0. 3003 1)

The maximum deflection occurs at the end of the rod and was found to be 6.2mm as shown above.

Stress:

Ny {1 0OMNW SO0

iy = 7 = = 64.9MPa

(=712 5mim =10 5mimyd

The maximum stress occurs at the base of the rod and was found to be 64.9MPa as shown above (pure
bending stress).

2. Results Using ANSYS
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Deformation

o from the Main Menu select General Postproc from the '"ANSYS Main Menu'. In this menu you
will find a variety of options, the two which we will deal with now are 'Plot Results' and 'List
Results'

o Select Plot Results > Deformed Shape.

o Select 'Def + undef edge' and click 'OK' to view both the deformed and the undeformed object.

J\ ANSYS Graphics PLDISP,2

DI SFLACDMINT

ITEFIL By £4 EO0L
Im =1 15:81:17
TIME=1

Iem =6.103

o Observe the value of the maximum deflection in the upper left hand corner (shown here surrounded
by a blue border for emphasis). This is identical to that obtained via hand calculations.

Deflection
For a more detailed version of the deflection of the beam,
o From the 'General Postproc' menu select Plot results > Contour Plot > Nodal Solution.

o Select 'DOF solution' and 'USUM'. Leave the other selections as the default values. Click 'OK'.
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o You may want to have a more useful scale, which can be accomplished by going to the Utility
Menu and selecting Plot Controls > Style > Contours > Uniform Contours

o The deflection can also be obtained as a list as shown below. General Postproc > List Results >
Nodal Solution ... select 'DOF Solution' and 'ALL DOFs' from the lists in the 'List Nodal Solution'
window and click 'OK'. This means that we want to see a listing of all translational and rotational
degrees of freedom from the solution. If we had only wanted to see the displacements for example,
we would have chosen 'ALL Us' instead of 'ALL DOFs'.
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A PRNSOL Command
Eie
FRINT DOF MWODAL SOLUTIOM FER MODE
wewun POST1 HODAL DEGREE OF FREEDOM LISTIHG wwsss
LOAD STEF= 1 SUBSTEP= i
TIRE= 10888 LOAD CRASE= ]
THE FOLLOWING DEGREE OF FREEDOM RESEULTS ARE IN GLOBAL COORDINATES
HODE ILE] uy Uz ROTH ROTY ROTZ
i @.aaaa . peEe B . BERa 3. pA8ea B. 888 a.aaa
2 a.88aa =b . 20R5 . aeaa 3. #8aa . BBaa -A.18547E-A1
3 . Baaa -H.15691E-01 B.Bb0s 3. BaPa 0. aaea =8.14541 E-82
4 0. 0888 -A.57870E-81 B.D0E8 B paes B.eeea -8. HEE-B2
5 . aaaa -A.13135 0. BeBE B. 888 B. 8888 -8.41841 E-82
] a.aapa -A.228%94 B . BEE 3. 688 B. 8888 -8.54682 E-82
7 a.aaaa -8.35146 0. BERa 3. pA8a B. 888 -8.66768E-82
B @.aaaa =A.49772 B . BERa 3. pABaa . Aaaa -8.78341 E-82
9 . Aaaa =HA.666%54 0. aE 3. paea . AaEa -0.89321 E-82
18 [IME15 0] -d.8 B BERE 3. paea 0. ARPa -8.99787E-82
11 a.aaaa -1 .8671 B BeRE 3. Baea B. 888 -8.18958E-81
12 A.86808 -1.2964 . aaaa 3. 8a8a 0. 8aaa -B.11878E-81
13 @.8aaa -1.5436 0. EEE 5. 6888 6. 8888 -8.12738E-81
i4 a.aaaa -1.8874 B . BERE 5. AABEA B.A88a -8.13532E-81
15 a.aaaa =2 . BEG6 B . BaRa 3. paaa . aaaa =0.14274E-81
16 B.P888 =-2. 8. B [ H_ARRA -8.14956 E-#1
17 . BaBa =2 _BBES B R 3. Baea B.8Pa -8 15579 E-#1
18 A.aaaa —3.084% B . BeBE 3. 688 B. 8888 -A.16143E-81
19 @.aaaa -3.333% B . EEE 3. 6888 6. 8888 -#.16648 E-81
28 @.aaaa -3.6725 B . BERa 3. pA8ea B. 888 -8.17873E-81
21 a.0aan =4.8193 . aaaa 3. #8aA . BBaa =A.17478E-A1
22 . 8aaa =4.3733 B Baha 3. BaPa 0. aaea =8.17885E-81
23 0. 0888 -4_.7333 B . Bepa 3. paes B.eeea -8.18872E-81
24 . a8aa =5.897% 0. BeBE 3. Baea B. a88a -f.1828BE-81
25 a.aaaa —5.4661 0. BERE 3. 6888 B. 8888 -A.18428E-81
26 @.aaaa -5.8367 B . B8 5. 6a88 6. 888 -8.18517E-81
HAXIHUA ABSOLUTE VALUES
HODE 5] a 3] 2
UALUE B aaBa —h . 28RS B B B . Baaa 3. aaea -8.18547E-81

o Are these results what you expected? Again, the maximum deflection occurs at node 2, the right
end of the rod. Also note that all the rotational and translational degrees of freedom were
constrained to zero at node 1.

o If you wanted to save these results to a file, use the mouse to go to the 'File' menu (at the upper left-
hand corner of this list window) and select 'Save as'.

Stresses

For line elements (ie beams, spars, and pipes) you will need to use the Element Table to gain access to
derived data (ie stresses, strains).

o From the General Postprocessor menu select Element Table > Define Table...

o Click on'Add...'
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fiYoefine additional Element Table Ttems =

[AVPRIN] EFF MU For EQV strain |.;.
[ETABLE] Dwfire Addiional Elemant Table fems
Lab  Lkser lsbel for Rem

Thesm, Comp Foesults data em

(For "By smquence pign”, shter sequerce
. in Sedection box. Ses Tabls 4.000-3
in Elnrrents Marwal For seq. rumbers, )

e 0 Ee| . el e

o As shown above, in the 'Ttem,Comp' boxes in the above window, select 'Stress' and 'von Mises
SEQV'

o Click on 'OK' and close the 'Element Table Data' window.
o Plot the Stresses by selecting Plot Elem Table in the Element Table Menu

o The following window will appear. Ensure that 'SEQV" is selected and click 'OK'

mcuntuur Plot of Element Table Data = ':i- i =
[PLETAB] Contour Element Table Data
Itlsb  Ttern ko be plothed ﬁ

Avglab Average at common nodes?

o If'you changed the contour intervals for the Displacement plot to "User Specified" you may need to
switch this back to "Auto calculated" to obtain new values for VMIN/VMAX.
Utility Menu > PlotCtrls > Style > Contours > Uniform Contours ...
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Again, select more appropriate intervals for the contour plot

o List the Stresses
» From the 'Element Table' menu, select 'List Elem Table'
= From the 'List Element Table Data' window which appears ensure 'SEQV"' is highlighted
= Click 'OK'

Note that a maximum stress of 64.914 MPa occurs at the fixed end of the beam as predicted
analytically.

Bending Moment Diagrams

To further verify the simplified model, a bending moment diagram can be created. First, let's look at how
ANSYS defines each element. Pipe 16 has 2 nodes; I and J, as shown in the following image.

(L —_—
Node 1 Node J

To obtain the bending moment for this element, the Element Table must be used. The Element Table
contains most of the data for the element including the bending moment data for each element at Node I
and Node J. First, we need to obtain obtain the bending moment data.

o General Postproc > Element Table > Define Table... . Click 'Add...".
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P pefine Additional Element Table Items e =]

[AVPREN] EXf MU Fior ECHY strsin ID
[ETAELE] Define Additional Eksment Table Tems
Lab WLkser Lsbed For ibem

Them, Comp Rests data e

(For "By sequence num™, enter sequence
0, in Selection boc. Ses Takds 4,003
in Elements Manual for saq. rumbers.)

gz P fEEE | BT

o In the window,

Enter IMoment as the 'User label for item' - this will give a name to the data
Select 'By sequence num' in the Item box

Select 'SMISC' in the first Comp box

Enter sMIsc, 6 in the second Comp box

Click 'OK'

monw>

This will save all of the bending moment data at the left hand side (I side) of each element. Now we
need to find the bending moment data at the right hand side (J side) of each element.

o Again, click 'Add..." in the 'Element Table Data' window.

Enter oMoment as the 'User label for item' - again, this will give a name to the data
Same as above

Same as above

For step D, enter sMISC, 12 in the second Comp box

Click 'OK'

moYaQw>

o Click 'Close' in the 'Element Table Data' window and close the 'Element Table' Menu. Select Plot
Results > Contour Plot > Line Elem Res...

Fi\elot Line-Element Results |

[PLLS] Plot Line-Elament Result

Labl Elem table ikem 2k node I fovenT Rl
Labd Elem kable ke at node J IMOMENT vi
Fack Optionsl scabs Fackor ||

KUND Theins bo be plotbed

(+ Def shape only
(™ Def + undeformed
(" Def + undaf edge

24 Apply Cancel Help

o From the 'Plot Line-Element Results' window, select IMOMENT" from the pull down menu for
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Labl, and '"MOMENT' from the pull down menu for LabJ. Click 'OK'. Note again that you can
modify the intervals for the contour plot.

J\ ANSYS Graphics  PLLS,IMOMENT, JMOMENT, 1,0

1
LI ITREZZ

ITE=L
B =1
TIHEE1
IMQACHT JEMEENT

Now, you can double check these solutions analytically. Note that the line between the I and J point
is a linear interpolation.

o Before the explanation of the above steps, enter help pipel6 in the command line as shown
below and then hit enter.

==

help p'pBIEi ﬂ | g

o Briefly read the ANSYS documentation which appears, pay particular attention to the Tables near
the end of the document (shown below).

Table 1. PIPE16 Item, Sequence Numbers, and Definitions for the ETABLE Commands

| node I |
| |
| name || item || e ||Deﬁnition |
IMFORX  |[SMISC || 1 || pember
IMFORY  [ISMISC || 2 | forces at the
IMFORZ  |[smisc || 3 | node
IMMOMX _ [ISMISC || 4 | pember
|MMOMY ||SMISC || 5 | moments at
IMMOMZ J[smisc || 6 | thenode
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Note that SMISC 6 (which we used to obtain the values at node I) correspond to MMOMZ - the
Member moment for node 1. The value of 'e' varies with different Element Types, therefore you
must check the ANSYS Documentation files for each element to determine the appropriate SMISC
corresponding to the plot you wish to generate.

Command File Mode of Solution

The above example was solved using the Graphical User Interface (or GUI) of ANSYS. This problem can also
been solved using the ANSYS command language interface. To see the benefits of the command line clear your
current file:

e From the Utility menu select: File > Clear and Start New
¢ Ensure that 'Read File' is selected then click 'OK'
¢ seclect 'yes' in the following window.

Copy the following code into the command line, then hit enter. Note that the text following the "!" are
comments.

/PREP7 ! Preprocessor

K,1,0,0,0, ! Keypoint, 1, x, vy, z

K,2,500,0,0, ! Keypoint, 2, x, vy, z

L,1,2 ! Line from keypoint 1 to 2

| %

ET,1,PIPELlG6 ! Element Type = pipe 16

KEYOPT,1,6,1 ! This is the changed option to give the extra force and moment ou
| %

R,1,25,2, ! Real Constant, Material 1, Outside Diameter, Wall thickness
| %

MP,EX,1,70000 ! Material Properties, Young's Modulus, Material 1, 70000 MPa
MP, PRXY,1,0.33 ! Material Properties, Major Poisson's Ratio, Material 1, 0.33
| %

LESIZE,ALL, 20 ! Element sizes, all of the lines, 20 mm

LMESH, 1 ! Mesh the lines

FINISH ! Exit preprocessor

/SOLU ! Solution

ANTYPE, O ! The type of analysis (static)

| x

DK,1, ,0, ,0,ALL ! Apply a Displacement to Keypoint 1 to all DOF

FK,2,FY,-100 ! Apply a Force to Keypoint 2 of -100 N in the y direction
/STATUS, SOLU

SOLVE ! Solve the problem

FINISH

Note that you have now finished Postprocessing and the Solution Phase with just these few lines of code. There
are codes to complete the Postprocessing but we will review these later.

Bicycle Example

Now we will return to the analysis of the bike frame. The steps which you completed in the verification
example will not be explained in great detail, therefore use the verification example as a reference as required.
We will be combining the use of the Graphic User Interface (GUI) with the use of command lines.

Recall the geometry and dimensions of the bicycle frame:
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Preprocessing: Defining the Problem

1. Clear any old ANSYS files and start a new file
Utility Menu > File > Clear and Start New

2. Give the Example a Title
Utility menu > File > Change Title

3. Defining Some Variables

We are going to define the vertices of the frame using variables. These variables represent the various
lengths of the bicycle members. Notice that by using variables like this, it is very easy to set up a
parametric description of your model. This will enable us to quickly redefine the frame should changes be
necessary. The quickest way to enter these variables is via the '"ANSYS Input' window which was used
above to input the command line codes for the verification model. Type in each of the following lines
followed by Enter.

x1 = 500
X2 = 825
yl = 325
y2 = 400
z1l = 50

4. Enter Keypoints
For this space frame example, these keypoints are the frame vertices.

o We are going to define 6 keypoints for this structure as given in the following table (these
keypoints are depicted by the circled numbers in the above figure):

coordinate

keypoint

x|y z
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1 0 lyl|f O
2 0 |ly2(f O
3 xl||y2{| O
4 x1||Of O
5 x2| 0 | z1
6 x2|[ 0 |-zl

o Now instead of using the GUI window we are going to enter code into the 'command line'. First,
open the 'Preprocessor Menu' from the '"ANSYS Main Menu'. The preprocessor menu has to be
open in order for the preprocessor commands to be recognized. Alternatively, you can type /PREP7
into the command line. The command line format required to enter a keypoint is as follows:

K, NPT, X, Y, Z
where, each Abbreviation is representative of the following:
Keypoint, Reference number for the keypoint, coords x/y/z
For a more detailed explanation, type help k into the command line
For example, to enter the first keypoint type:
K,1,0,vy1,0
into the command line followed by Enter.

As with any programming language, you may need to add comments. The exclamation mark
indicates that anything following it is commented out. ie - for the second keypoint you might type:

K,2,0,y2,0 ! keypoint, #, x=0, y=y2, z=0
o Enter the 4 remaining keypoints (listed in the table above) using the command line
o Now you may want to check to ensure that you entered all of the keypoints correctly:

Utility Menu > List > Keypoints > Coordinates only
(Alternatively, type 'KLIST' into the command line)

Els

LIST ALL SELECTED KEYPOIHTE. DEYE= a

HO. X.¥.Z LOCATION HESIZE HODE ELEH HAT REAL TYFP ERYS
i 8.88 325. a.88 8. 88 a a 8 a 8 a
- 488, .88 8. 88 1] a @ a @ [
3 5Ed. 4Hd . H.88 a. a8 1] a @ a @ [
4 588, a.80 a.88 f. 88 a [ B 8 [
5 B35S, a.88 50.8 a. 88 ] a @ A @ 2]
6 B2, a.88 -50.8 a. 88 a a @ a @ A

o If'there are any keypoints which need to be re-entered, simply re-enter the code. A previously
defined keypoint of the same number will be redefined. However, if there is one that needs to be
deleted simply enter the following code:
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KDELE, 4

where # corresponds to the number of the keypoint.

In this example, we defined the keypoints by making use of previously defined variables like y1 = 325.
This was simply used for convenience. To define keypoint #1, for example, we could have alternatively
used the coordinates x =0,y =325,z=0.

5. Changing Orientation of the Plot

o To get a better view of our view of our model, we'll view it in an isometric view:

o Select Utility menu bar > PlotCtrls > Pan, Zoom, Rotate...'

Pan-Zoom-Rotake

;

t|ELl
ekl
Elislels

J
:
:
:

A
iy
v

| BEE
- |REE

¢

[ Dynamic Mods
£ b

R (et |
e

-

6. Create Lines

e In the window that appears (shown left),
you have many controls. Try
experimenting with them. By turning on
the dynamic mode (click on the
checkbox beside 'Dynamic Mode') you
can use the mouse to drag the image,
translating and rotating it on all three
axes.

e To get an isometric view, click on
'Iso' (at the top right). You can either
leave the 'Pan, Zoom, Rotate' window
open and move it to an empty area on
the screen, or close it if your screen is
already cluttered.

We will be joining the following keypoints together:

keypoint . . . .
line yp Again, we will use the command line to create the lines. The command format to cre
1st||2nd || straight line looks like:
1 1 2 L, Pl, P2
5 5 3 Line, Keypoint at the beginning of the line, Keypoint at the end c
3 3 4 For example, to obtain the first line, I would write: ' ,1,2 '
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Note: unlike 'Keypoints', 'Lines' will automatically assign themselves the next availal
reference number.

=] | =) 9] =

Bllw]| &l w
allanlln]lwv]| &

o Enter the remaining lines until you get a picture like that shown below.

o Again, check to ensure that you entered all of the lines correctly: type ' LLIST 'into the command
line

o If there are any lines which need to be changed, delete the line by typing the following code: '
LDELE, # 'where # corresponds to the reference number of the line. (This can be obtained from the

list of lines). And then re-enter the line (note: a new reference number will be assigned)

You should obtain the following:

nAHE"l"E Graphics LPLOT type=1 mat=1 real=1 csys=0

1
LINEE

TYFE WM

3D Bicycle 3pace Frame

7. Define the Type of Element
Preprocessor > Element Type > Add/Edit/Delete > Add

As in the verification model, define the type of element (pipel6). As in the verification model, don't
forget to change Option K6 'Include Output' to obtain extra force and moment output.

8. Define Geometric Properties
Preprocessor > Real Constants > Add/Edit/Delete

Now specify geometric properties for the elements
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Outside diameter OD: 25
Wall thickness TKWALL: 2

9. Element Material Properties

To set Young's Modulus and Poisson's ratio, we will again use the command line. (ensure that the
preprocessor menu is still open - if not open it by clicking Preprocessor in the Main Menu)

MP, LAB, MAT, CO
Material Property,Valid material property label, Material Reference Number, v

o To enter the Elastic Modulus (LAB = EX) of 70000 MPa, type: ' MP,EX,1,70000 '
o To set Poisson's ratio (PRXY), type ' MP,PRXY,1,0.33 '
10. Mesh Size

As in the verification model, set the element length to 20 mm
Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > All Lines

11. Mesh

Now the frame can be meshed.
o In the 'Preprocessor' menu select 'Mesh' > 'Lines' and click 'Pick All' in the 'Mesh Lines' Window

Saving Your Job
Utility Menu > File > Save as...

Solution Phase: Assigning Loads and Solving
Close the 'Preprocessor’ menu and open up the 'Solution' menu (from the same 'ANSYS Main Menu').

1. Define Analysis Type
Solution > Analysis Type > New Analysis... > Static

2. Apply Constraints
Once again, we will use the command line. We are going to pin (translational DOFs will be fixed) the

first keypoint and constrain the keypoints corresponding to the rear wheel attachment locations in both
the y and z directions. The following is the command line format to apply constraints at keypoints.

DK, KPOI, Lab, VALUE, VALUE2, KEXPND, Lab2, Lab3, Lab4, Lab5, Labé6
Displacement on K, K #, DOF label, value, value2, Expansion key, other DOF la

Not all of the fields are required for this example, therefore when entering the code certain fields will be
empty. For example, to pin the first keypoint enter:

DK,1,UX,0,,,UY,UZ

The DOF labels for translation motion are: UX, UY, UZ. Note that the 5™ and 6™ fields are empty. These
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correspond to 'value2' and 'the Expansion key' which are not required for this constraint. Also note that all
three of the translational DOFs were constrained to 0. The DOFs can only be contrained in 1 command
line if the value is the same.

To apply the contraints to Keypoint 5, the command line code is:
DK, 5,U0Y,0,,,UZ

Sth 6th

Note that only UY and UZ are contrained to 0. UX is not constrained. Again, note that the 5 and
fields are empty because they are not required.
o Apply the constraints to the other rear wheel location (Keypoint 6 - UY and UZ).

o Now list the constraints ('DKLIST') and verify them against the following:

JADELIST Command [ %]
Eiler

I
LIST SELECTED DOF COMSTRAINTE OM ALL SELECTED KEYPDIMIS
CURRENTLY SELECTED DOF SET- UX uy Uz ROTHX ROTY ROTZ

HKEY E‘DiHT LOAD LABEL UHIéHE(S} EXP KEY

s a8aa . aeaa a
1 uy a.8e8a a.8eaa a
i Uz A.8888 B.8888 5]
S uy 8. aesa 8. aeaa a
S Uz a. 8888 a.a8aa a
B uy A.8888 A.8888 5]
[ Uz 8. 88 8. aeaa a

If you need to delete any of the constraints use the following command: 'DKDELE, K, Lab' (ie
'DKDELE, 1,U2' would delete the constraint in the 'z' direction for Keypoint 1)

3. Apply Loads

We will apply vertical downward loads of 600N at the seat post location (keypoint 3) and 200N at the
pedal crank location (keypoint 4). We will use the command line to define these loading conditions.

FK, KPOI, Lab, value, value2
Force loads at keypoints, K #, Force Label directions (FX, FY, FZ), valuel, value2 (i

To apply a force of 600N downward at keypoint 3, the code should look like this: ' Fk,3,Fy,-600 '
Apply both the forces and list the forces to ensure they were inputted correctly (FKLIST).

If you need to delete one of the forces, the code looks like this: 'FKDELE, K, Lab' (ie 'FKDELE, 3, FY'
would delete the force in the 'y’ direction for Keypoint 3)

The applied loads and constraints should now appear as shown below.
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J\ ANSYS Graphics eplot El=1 =] B3

1
ELEMENTZ

30 Bicycle Space Frame

4. Solving the System
Solution > Solve > Current LS

Postprocessing: Viewing the Results
To begin Postprocessing, open the 'General Postproc' Menu

1. Deformation
Plot Results > Deformed Shape... 'Def + undef edge'
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J\ ANSYS Graphics PLDISP,? E= =k

1
DISFLACEMENT
ITE=1
B 1
TIHE:=1
D0 = fE95E4

o You may want to try plotting this from different angles to get a better idea what's going on by using
the 'Pan-Zoom-Rotate' menu that was earlier outlined.

o Try the 'Front' view button (Note that the views of 'Front', 'Left', 'Back’, etc depend on how the
object was first defined).

o Your screen should look like the plot below:

J\ ANSYS Graphics PLDISP,2 E= M=

1

DI ZPLALEMENT
ITEEL

JUB Rl
TIME:=1

DEE. = IE95E4

2. Deflections
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Now let's take a look at some actual deflections in the frame. The deflections have been calculated at the
nodes of the model, so the first thing we'll do is plot out the nodes and node numbers, so we know what
node(s) we're after.

o Go to Utility menu > PlotCtrls > Numbering... and turn on 'Node numbers'. Turn everything else
off.

o Note the node numbers of interest. Of particular interest are those nodes where the constraints were
applied to see if their displacements/rotations were indeed fixed to zero. Also note the node
numbers of the seat and crank locations.

o List the Nodal Deflections (Main Menu > General Postproc > List Results > Nodal Solution...").
Are the displacements and rotations as you expected?

o Plot the deflection as well.
General Postproc > Plot Results > (-Contour Plot-) Nodal Solution select 'DOF solution'
and 'USUM' in the window

J\ ANSYS Graphics PLNSOL,U,SUM,0,1

: HOD&L SOLUTIOH AN S&rs

T LS ool
15:19:4%

o Don't forget to use more useful intervals.
3. Element Forces
We could also take a look at the forces in the elements in much the same way:

o Select 'Element Solution...' from the 'List Results' menu.

o Select 'Nodal force data' and 'All forces' from the lists displayed.

o Click on 'OK".

o For each element in the model, the force/moment values at each of the two nodes per element will
be displayed.

o Close this list window when you are finished browsing.
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o Then close the 'List Results' menu.
4. Stresses
As shown in the cantilever beam example, use the Element Table to gain access to derived stresses.

General Postproc > Element Table > Define Table ...
Select 'Add'
Select 'Stress' and 'von Mises'

O
O
O
o Element Table > Plot Elem Table

J\ ANSYS Graphics PLETAB,SEQY,NDAY Elz] M=] E3

ELEMENT SO0LUTION

STERP=1
SUE =1

o Again, select appropriate intervals for the contour plot
5. Bending Moment Diagrams
As shown previously, the bending moment diagram can be produced.
Select Element Table > Define Table... to define the table (remember SMISC,6 and SMISC,12)

And, Plot Results > Line Elem Res... to plot the data from the Element Table
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J\ ANSYS Graphics PLLS,JIMOMENT,JMOMENT, 1
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3 Bicycle Space Frame

Command File Mode of Solution

The above example was solved using a mixture of the Graphical User Interface (or GUI) and the command
language interface of ANSYS. This problem has also been solved using the ANSYS command language
interface that you may want to browse. Open the file and save it to your computer. Now go to 'File > Read
input from..." and select the file.

Quitting ANSYS

To quit ANSYS, select 'QUIT' from the ANSYS Toolbar or select 'Utility Menu'/'File'/'Exit...". In the dialog box
that appears, click on 'Save Everything' (assuming that you want to) and then click on 'OK".
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