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Plane Stress Bracket

Introduction

This tutorial is the second of three basic tutorials created to illustrate commom features in ANSYS. The plane
stress bracket tutorial builds upon techniques covered in the first tutorial (3D Bicycle Space Frame), it is
therefore essential that you have completed that tutorial prior to beginning this one.

The 2D Plane Stress Bracket will introduce boolean operations, plane stress, and uniform pressure loading.

Problem Description

The problem to be modeled in this example is a simple bracket shown in the following figure. This bracket is to
be built from a 20 mm thick steel plate. A figure of the plate is shown below.

This plate will be fixed at the two small holes on the left and have a load applied to the larger hole on the right.

Verification Example

The first step is to simplify the problem. Whenever you are trying out a new analysis type, you need something
(ie analytical solution or experimental data) to compare the results to. This way you can be sure that you've
gotten the correct analysis type, units, scale factors, etc.

The simplified version that will be used for this problem is that of a flat rectangular plate with a hole shown in
the following figure:
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Preprocessing: Defining the Problem

1. Give the Simplified Version a Title
Utility Menu > File > Change Title

2. Form Geometry
Boolean operations provide a means to create complicated solid models. These procedures make it easy to

combine simple geometric entities to create more complex bodies. Subtraction will used to create this
model, however, many other Boolean operations can be used in ANSYS.

a. Create the main rectangular shape

Instead of creating the geometry using keypoints, we will create an area (using GUI)
Preprocessor > Create > (-Areas-) Rectangle > By 2 Corners
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= Fill in the window as shown above. This will create a rectangle where the bottom left corner
has the coordinates 0,0,0 and the top right corner has the coordinates 200,100,0.

(Alternatively, the command line code for the above command is BLc4,0,0,200,100)

b. Create the circle
Preprocessor > Create > (-Areas-) Circle > Solid Circle

M\ Solid Circular Area [ <]

Apply

Cancel

= Fill in the window as shown above. This will create a circle where the center has the

Copyright © 2001 University of Alberta



University of Alberta ANSYS Tutorials - www.mece.ualberta.ca/tutorials/ansys/BT/Bracket/Bracket.html

coordinates 100,50,0 (the center of the rectangle) and the radius of the circle is 20 mm.
(Alternatively, the command line code for the above command is cyL4,100,50,20 )
c. Subtraction

Now we want to subtract the circle from the rectangle. Prior to this operation, your image
should resemble the following:

J\ ANSYS Graphics aplot type=1 mat=1 real=1 csys=0

1
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» To perform the Boolean operation, from the Preprocessor menu select:
(-Modeling-) Operate > (-Booleans-) Subtract > Areas >

= At this point a 'Subtract Areas' window will pop up and the ANSY'S Input window will

display the following message: [ASBA] Pick or enter base areas from which to
subtract (as shown below)

M\ BHSYS Input

[ASBA]l Pick or enter base areaz from which to subtract

= Therefore, select the base area (the rectangle) by clicking on it. Note: The selected area will
turn pink once it is selected.

= The following window may appear because there are 2 areas at the location you clicked.
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= Ensure that the entire rectangular area is selected (otherwise click Next') and then click 'OK".

= Click 'OK' on the 'Subtract Areas' window.

= Now you will be prompted to select the areas to be subtracted, select the circle by clicking on
it and then click 'OK'.

You should now have the following model:

J\ ANSYS Graphics aplot type=1 mat=1 real=1 csys=0

1
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(Alternatively, the command line code for the above step is AsBa, 1, 2)
3. Define the Type of Element
It is now necessary to define the type of element to use for our problem:
Preprocessor Menu > Element Type > Add/Edit/Delete

o Add the following type of element: Solid (under the Structural heading) and the Quad 82 element,
as shown in the above figure.
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PLANES?2 is a higher order version of the two-dimensional, four-node element (PLANE42).
PLANES?2 is an eight noded quadrilateral element which is better suited to model curved
boundaries.

For this example, we need a plane stress element with thickness, therefore

o Click on the 'Options..." button. Click and hold the K3 button, and select 'Plane strs w/thk', as
shown below.

i PLANEBZ element type oplions

Mo extra output =
Ho extra output -

(Alternatively, the command line code for the above step is ET, 1, PLANES2 followed by
KEYOPT,1,3,3)

4. Define Geometric Properties
o As in previous examples Preprocessor menu > Real Constants > Add/Edit/Delete

o Enter a thickness of 20 as shown in the figure below. This defines a plate thickness of 20mm)

: Real Conskant Set Number 1, for PLANEEZ
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(Alternatively, the command line code for the above step is R, 1,20)
5. Element Material Properties
o As shown in previous examples, select Preprocessor > Material Props > Material models >
Structural > Linear > Elastic > Isotropic
We are going to give the properties of Steel. Enter the following when prompted:

EX 200000
PRXY 0.3

(Alternatively, the command line code for the above step is MP,Ex,1,200000 followed by
MP,PRXY,1,0.3)

6. Mesh Size

To tell ANSYS how big the elements should be, Preprocessor > (-Meshing-) Size Cntrls > (-Areas-)
All Areas

i Element Sizes on All Selected Areas Ed

o | ey | caeer || e |

o Select an element edge length of 25. We will return later to determine if this was adequate for the
problem.

(Alternatively, the command line code for the above step is AESIZE,ALL,25,)
7. Mesh

Now the frame can be meshed.
o In the 'Preprocessor' menu select Mesh > (-Areas-) Free and select the area when prompted

(Alternatively, the command line code for the above step is AMESH,ALL)

You should now have the following:
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nAHS"l"S Graphics eplot type=1 mat=1 real =] =] E3

Saving Your Job
Utility Menu > File > Save as...

Solution Phase: Assigning Loads and Solving

You have now defined your model. It is now time to apply the load(s) and constraint(s) and solve the the
resulting system of equations.

1. Define Analysis Type
o Ensure that a Static Analysis will be performed (Solution > New Analysis).
(Alternatively, the command line code for the above step is ANTYPE, 0)
2. Apply Constraints

As shown previously, the left end of the plate is fixed.
o In the Solution > (-Loads-) Apply > (-Structural-) Displacement > 'On Lines'

o Select the left end of the plate and click on 'Apply' in the 'Apply U,ROT on Lines' window.

o Fill in the window as shown below.
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: Apply UROT on Lines
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o This location is fixed which means that all DOF's are constrained. Therefore, select 'All DOF' by
clicking on it and enter '0' in the Value field as shown above.

You will see some blue triangles in the graphics window indicating the displacement contraints.
(Alternatively, the command line code for the above step is DL, 4, ,ALL, 0)
3. Apply Loads
o As shown in the diagram, there is a load of 20N/mm distributed on the right hand side of the plate.
To apply this load:
Solution > (-Loads-) Apply > (-Structural-) Pressure > On Lines

o When the window appears, select the line along the right hand edge of the plate and click 'OK'

o Calculate the pressure on the plate end by dividing the distributed load by the thickness of the plate
(1 MPa).

o Fill in the "Apply PRES on lines" window as shown below. NOTE:
» The pressure is uniform along the surface of the plate, therefore the last field is left blank.
» The pressure is acting away from the surface of the plate, and is therefore defined as a
negative pressure.
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: Apply PRES on lines [ %]

[SFL1 Apply PREE on lines as a |Constant value =

If Constant wvalue then:

UVALUE Load PRES wvalue |—1

If Constant walue then:
Optional PRES values at end J of line
{leave hlank for wuniform PRES >

Ualue Ii

Apply Cancel | Help I

The applied loads and constraints should now appear as shown below.

4. Solving the System
Solution > (-Solve-) Current LS

Postprocessing: Viewing the Results

1. Hand Calculations

Now, since the purpose of this exercise was to verify the results - we need to calculate what we should
find.

Deflection: The maximum deflection occurs on the right hand side of the plate and was calculated to be
0.001 mm - neglecting the effects of the hole in the plate (ie - just a flat plate). The actual deflection of
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the plate is therefore expected to be greater but in the same range of magnitude.

Stress: The maximum stress occurs at the top and bottom of the hole in the plate and was found to be 3.9
MPa.

2. Convergence using ANSYS

At this point we need to find whether or not the final result has converged. We will do this by looking at
the deflection and stress at particular nodes while changing the size of the meshing element.

Since we have an analytical solution for the maximum stress point, we will check the stress at this
point. First we need to find the node corresponding to the top of the hole in the plate. First plot and
number the nodes

Utility Menu > Plot > Nodes

Utility Menu > PlotCtrls > Numbering...

o The plot should look similar to the one shown below. Make a note of the node closest to the top of
the circle (ie. #49)

J\ ANSYS Graphics NPLOT

fLiEs

HODE EURY

o List the stresses (General Postproc > List Results > Nodal Solution > Stress, Principals SPRIN)
and check the SEQV (Equivalent Stress / von Mises Stress) for the node in question. (as shown
below in red)
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S\ PRNSOL Command E I

Eh'
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PRINWT & HODAL SOLUTION PER HODE =
s POSTL NODAL STRESS LISTING sessae
PowerGraphics Is Currently Enahbled
LOAD STEP= i SUBSTEP= i
TIHE= 1.8088 LOAD CASE= a
HODAL RESULTS ARE FOR HATERIAL 1
HODE 51 52 53 SINT [SEQU |
1 1.3347 B.23881 B.8088 1.3347 1.235%8
2 B.97892 8.80a8 -8.48632E-82 B.97578 8.97336
4 1.1186 a.8888 -8,.79514E-81 1.1981 1.1524
b 1.33%96 a.8088 -8.23728E-81 1.3633 1.3516
8 1.5283 8.80ea =B.12827 1.6486 1.5918
i@ B.27083 B.17884 2.8008 B.37083 B.32148
12 1.5365 2.88688 -B.11828 1.6547 1.5988
14 1.3684 A.8888 -8.26629E-81 1.3871 1.3748
16 1.183% 8.80688 -B.12367E-81 1.1163 1.1182 —
18 B8.97098 B.8088 -8.44265E-82 B8.97533 B8.97312
28 1.8183 B.78%33E-81 ©.0888 1.8183 a.97672
22 1.8113 B.17828 a.8a88 1.8113 a.%3583
24 1.68184 B.78622E-81 ©.0008 1.8184 a.9778a8|
26 1.3347 B.23128 B.6800808 1.3347 1.2354
28 1.1851 2.8088 -B.12481E-P1 1.117%6 1.1114
38 1.3581 2.8pea -B.26511E-81 1.3847 1.3716
32 1.5372 8.8e688 -B.11815% 1.6554 1.5996
34 B.37882 B.17885 a.8aaa B.37882 B8.32147
36 1.5275 8.8888 -8.1282% 1.6478 1.5911
38 1.3419 a.80a8 -8.23965E-81 1.3658 1.3548
48 1.10898 8.8088 -8.79743E-81 1.1895% 1.1517
43 B.972528 B.24567 8.8a88 A.92528 a.83817
45 B.88897 B.27391 8.8088 a.88897 a. 78854
47 B.92546 B.24573 2.808a B.92545 B.83P33
B.29745 8. a.g
92 1.2628 8.8808 -8.23686 1.4988 1.39% =«

The equivalent stress was found to be 2.9141 Mpa at this point. We will use smaller elements to try
to get a more accurate solution.

o Resize Elements
a. To change the element size, we need to go back to the Preprocessor Menu
Preprocessor > (-Meshing-) Size Cntrls > All Areas

now decrease the element edge length (ie 20)

b. Now remesh the model (Preprocessor > Mesh > (-Areas-) Free). Once you have selected
the area and clicked 'OK' the following window will appear:

: Remesh Entities E

c. Click 'OK'. This will remesh the model using the new element edge length.

d. Solve the system again (note that the constraints need not be reapplied). ( Solution Menu >
Current LS )

o Repeat steps 'a' through 'd' until the model has converged. (note - the number of the node at the top
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of the hole has most likely changed. It is essential that you plot the nodes again to select the
appropriate node). Plot the stress/deflection at varying mesh sizes as shown below to confirm that
convergence has occured.

0.000&50 400
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E =
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Number of Ele ments

Note the shapes of both the deflection and stress curves. As the number of elements in the mesh increases
(ie - the element edge length decreases), the values converge towards a final solution.

The von Mises stress at the top of the hole in the plate was found to be approximatly 3.8 MPa. This is a
mere 2.5% difference between the analytical solution and the solution found using ANSYS.

The approximate maximum displacement was found to be 0.0012 mm, this is 20% greater than the
analytical solution. However, the analytical solution does not account for the large hole in the center of
the plate which was expected to significantly increase the deflection at the end of the plate.

Therefore, the results using ANSYS were determined to be appropriate for the verification model.

3. Deformation

o General Postproc > Plot Results > Deformed Shape > Def + undeformd to view both the
deformed and the undeformed object.
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o Observe the locations of deflection.

4. Deflection
o General Postproc > Plot Results > Nodal Solution... Then select DOF solution, USUM in the
window.

J\ ANSYS Graphics PLNSOL,U,5UM,0,1

HODAL FOLUTION

o Alternatively, obtain these results as a list. (General Postproc > List Results > Nodal Solution...)

Copyright © 2001 University of Alberta



University of Alberta ANSYS Tutorials - www.mece.ualberta.ca/tutorials/ansys/BT/Bracket/Bracket.html
o Are these results what you expected? Note that all translational degrees of freedom were
constrained to zero at the left end of the plate.

5. Stresses
o General Postproc > Plot Results > Nodal Solution... Then select Stress, von Mises in the

window.

J\ ANSYS Graphics PLNSOL,S,EQV,0,1

NODAL FOLUTION

o You can list the von Mises stresses to verify the results at certain nodes
General Postproc > List Results. Select Stress, Principals SPRIN

Command File Mode of Solution

The above example was solved using the Graphical User Interface (or GUI) of ANSYS. This problem has also
been solved using the ANSYS command language interface that you may want to browse. Open the file and
save it to your computer. Now go to File > Read input from... and select the file.

Bracket Example

Now we will return to the analysis of the bracket. A combination of GUI and the Command line will be used for
this example.

The problem to be modeled in this example is a simple bracket shown in the following figure. This bracket is to
be built from a 20 mm thick steel plate. A figure of the plate is shown below.
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This plate will be fixed at the two small holes on the left and have a load applied to the larger hole on the right.

Preprocessing: Defining the Problem

1. Give the Bracket example a Title
Utility Menu > File > Change Title

2. Form Geometry
Again, Boolean operations will be used to create the basic geometry of the Bracket.
a. Create the main rectangular shape

The main rectangular shape has a width of 80 mm, a height of 100mm and the bottom left corner is
located at coordinates (0,0)

» Ensure that the Preprocessor menu is open. (Alternatively type /PREP7 into the command
line window)

= Now instead of using the GUI window we are going to enter code into the 'command line'.
Now I will explain the line required to create a rectangle:

BLC4, XCORNER, YCORNER, WIDTH, HEIGHT
BLC4, X coord (bottom left), Y coord (bottom left), width, height

» Therefore, the command line for this rectangle is BLc4,0,0,80,100

b. Create the circular end on the right hand side
The center of the circle is located at (80,50) and has a radius of 50 mm

The following code is used to create a circular area:

Copyright © 2001 University of Alberta



University of Alberta ANSYS Tutorials - www.mece.ualberta.ca/tutorials/ansys/BT/Bracket/Bracket.html

CYL4, XCENTER, YCENTER, RADI1

CYL4, X coord for the center, Y coord for the center, radius

m Therefore, the command line for this circle is cyrn.4,80,50, 50

c. Now create a second and third circle for the left hand side using the following dimensions:

parameter || circle 2 || circle 3
XCENTER|| 0 0
YCENTER |20 80
RADIUS |20 20

d. Create a rectangle on the left hand end to fill the gap between the two small circles.

XCORNER

-20

YCORNER

20

WIDTH

20

HEIGHT

60

Y our screen should now look like the following...

J\ aNsYS Graphics aplot type=1 mat=1 real=1 csys=0

HELAT
TIFE MY

e. Boolean Operations - Addition

We now want to add these five discrete areas together to form one area.

Copyright © 2001 University of Alberta



University of Alberta ANSYS Tutorials - www.mece.ualberta.ca/tutorials/ansys/BT/Bracket/Bracket.html
= To perform the Boolean operation, from the Preprocessor menu select:
Operate > -Booleans- Add > Areas >
» In the 'Add Areas' window, click on 'Pick All'
(Alternatively, the command line code for the above step is AADD , ALL)

Y ou should now have the following model:

J\ ANSYS Graphics aplot type=1 mat=1 real=1 csys=0
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f. Create the Bolt Holes
We now want to remove the bolt holes from this plate.

= Create the three circles with the parameters given below:

parameter || circle 1 || circle 2 || circle 3
WP X 80 0 0
WPY 50 20 80
radius 30 10 10

= Now select
Preprocessor > (-Modeling-) Operate > (-Booleans-) Subtract > Areas

= Select the base areas from which to subract (the large plate that was created)

= Next select the three circles that we just created. Click on the three circles that you just
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created and click 'OK".
(Alternatively, the command line code for the above step is ASBA, 6,ALL)
Now you should have the following:

J\ ANSYS Graphics aplot type=1 mat=1 real=1 csys=0

1
EPIAS
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2D Flane 3vzess Bracket

3. Define the Type of Element
As in the verification model, PLANES?2 will be used for this example
o Preprocessor > Element Type > Add/Edit/Delete
o Use the 'Options..." button to get a plane stress element with thickness

(Alternatively, the command line code for the above step is ET, 1, PLANES2 followed by
KEYOPT, 1,3,3)

o Under the Extra Element Output K5 select nodal stress.
4. Define Geometric Contants
o Preprocessor > Real Constants > Add/Edit/Delete
o Enter a thickness of 20mm.
(Alternatively, the command line code for the above step isR,1,20)

5. Element Material Properties
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o Preprocessor > Material Props > Material Library > Structural > Linear > Elastic > Isotropic
We are going to give the properties of Steel. Enter the following when prompted:

EX 200000
PRXY 0.3

(The command line code for the above step is MP,EX,1,200000 followed by MP, PRXY,1,0.3)
6. Mesh Size
o Preprocessor > (-Meshing-) Size Cntrls > (-Areas-) All Areas
o Select an element edge length of 5. Again, we will need to make sure the model has converged.
(Alternatively, the command line code for the above step is AESIZE,ALL,5,)
7. Mesh
o 'Preprocessor' > 'Mesh' > (-Areas-) 'Free' and select the area when prompted

(Alternatively, the command line code for the above step is AMESH, ALL)

A\ aNsYS Graphics eplot type=1 mat=1 real=1 csys=0

Saving Your Job
Utility Menu > File > Save as...

Solution Phase: Assigning Loads and Solving
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You have now defined your model. It is now time to apply the load(s) and constraint(s) and solve the the
resulting system of equations.
1. Define Analysis Type
o 'Solution' > 'New Analysis' and select 'Static'.
(Alternatively, the command line code for the above step is ANTYPE, 0)
2. Apply Constraints

As illustrated, the plate is fixed at both of the smaller holes on the left hand side.
o Solution > (-Loads-) Apply > (-Structural-) Displacement > On Nodes

o Instead of selecting one node at a time, you have the option of creating a box, polygon, or circle of
which all the nodes in that area will be selected. For this case, select 'circle' as shown in the window
below. (You may want to zoom in to select the points Utilty Menu / PlotCtrls / Pan, Zoom,
Rotate...) Click at the center of the bolt hole and drag the circle out so that it touches all of the
nodes on the border of the hole.

A

i+ \pick " Unpick

CiSingle [ Box

" Polygon (+ Circle
& Loss

Conarne = Q0
Maximum = l44l

Hinimum = 1
Node No. =

For Kevboard Encry:
" Lise of Items

7 Min, Hax, Inc

| (14 I Apply |

Regat Cancel ‘

_ p— | — |

o Click on 'Apply' in the 'Apply U,ROT on Lines' window and constrain all DOF's in the 'Apply
U,ROT on Nodes' window.

o Repeat for the second bolt hole.

3. Apply Loads
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As shown in the diagram, there is a single vertical load of 1000N, at the bottom of the large bolt hole.
Apply this force to the respective keypoint ( Solution > (-Loads-) Apply > (-Structural-)
Force/Moment > On Keypoints Select a force in the y direction of -1000)

The applied loads and constraints should now appear as shown below.

J\ ANSYS Graphics NPLOT El= 9= E

4. Solving the System

Solution > (-Solve-) Current LS

Post-Processing: Viewing the Results

We are now ready to view the results. We will take a look at the deflected shape and the stress contours once we
determine convergence has occured.

1. Convergence using ANSYS

At this point we need to find whether or not the final result has converged. Because we cannot
solve for a solution analytically, we must try to

2. Deformation

o General Postproc > Plot Results > Def + undeformed to view both the deformed and the
undeformed object.

The graphic should be similar to the following
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J\ ANSYS Graphics PLDISF,1
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o Observe the locations of deflection. Ensure that the deflection at the bolt hole is indeed 0.

3. Deflection

J\ ANSYS Graphics PLNSOL,U,SUM,0,1

L
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ZD Flans Zvzess Bracket

o Alternatively, obtain these results as a list. (General Postproc > List Results > Nodal Solution...)

o Are these results what you expected? Note that all translational degrees of freedom were
constrained to zero at the bolt holes.
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4. Stresses
o General Postproc > Plot Results > Nodal Solution... Then select von Mises Stress in the window.

nHNE‘I'S Graphics PLNSOL,SEQY,0,1
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o You can list the von Mises stresses to verify the results at certain nodes
General Postproc > List Results. Select Stress, Principals SPRIN

Command File Mode of Solution

The above example was solved using the Graphical User Interface (or GUI) of ANSYS. This problem has also
been solved using the ANSYS command language interface that you may want to browse. Open the file and
save it to your computer. Now go to 'File > Read input from...' and select the file.

Quitting ANSYS

To quit ANSYS, click 'QUIT' on the ANSYS Toolbar or select Utility Menu > File > Exit... In the window that
appears, select 'Save Everything' (assuming that you want to) and then click 'OK'.
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