
Transient Analysis of a Cantilever Beam  

Introduction  
This tutorial was created using ANSYS 7.0 The purpose of this tutorial is to show the steps involved to 
perform a simple transient analysis.  

  

Transient dynamic analysis is a technique used to determine the dynamic response of a structure under a 
time-varying load.  

The time frame for this type of analysis is such that inertia or damping effects of the structure are 
considered to be important. Cases where such effects play a major role are under step or impulse 
loading conditions, for example, where there is a sharp load change in a fraction of time.  

If inertia effects are negligible for the loading conditions being considered, a static analysis may be used 
instead.  

For our case, we will impact the end of the beam with an impulse force and view the response at the 
location of impact.  
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Since an ideal impulse force excites all modes of a structure, the response of the beam should contain all 
mode frequencies. However, we cannot produce an ideal impulse force numerically. We have to apply a 
load over a discrete amount of time dt.  

  

After the application of the load, we track the response of the beam at discrete time points for as long as 
we like (depending on what it is that we are looking for in the response).  

The size of the time step is governed by the maximum mode frequency of the structure we wish to 
capture. The smaller the time step, the higher the mode frequency we will capture. The rule of thumb in 
ANSYS is  

time_step = 1 / 20f  

where f is the highest mode frequency we wish to capture. In other words, we must resolve our step size 
such that we will have 20 discrete points per period of the highest mode frequency.  

It should be noted that a transient analysis is more involved than a static or harmonic analysis. It 
requires a good understanding of the dynamic behavior of a structure. Therefore, a modal 
analysis of the structure should be initially performed to provide information about the 
structure's dynamic behavior.  

In ANSYS, transient dynamic analysis can be carried out using 3 methods. 
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The Full Method: This is the easiest method to use. All types of non-linearities are allowed. It is 
however very CPU intensive to go this route as full system matrices are used. 

The Reduced Method: This method reduces the system matrices to only consider the Master 
Degrees of Freedom (MDOFs). Because of the reduced size of the matrices, the calculations are 
much quicker. However, this method handles only linear problems (such as our cantilever case). 

The Mode Superposition Method: This method requires a preliminary modal analysis, as 
factored mode shapes are summed to calculate the structure's response. It is the quickest of the 
three methods, but it requires a good deal of understanding of the problem at hand.  

We will use the Reduced Method for conducting our transient analysis. Usually one need not go further 
than Reviewing the Reduced Results. However, if stresses and forces are of interest than, we would have 
to Expand the Reduced Solution.  

Preprocessing: Defining the Problem  
The simple cantilever beam is used in all of the Dynamic Analysis Tutorials. If you haven't created the 
model in ANSYS, please use the links below. Both the command line codes and the GUI commands are 
shown in the respective links. 

Solution: Assigning Loads and Solving  
1. Define Analysis Type 

Select Solution > Analysis Type > New Analysis > Transient 

The following window will appear. Select 'Reduced' as shown. 

  

2. Define Master DOFs 

Select Solution > Master DOFs > User Selected > Define
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Select all nodes except the left most node (at x=0). 

The following window will open, choose UY as the first dof in this window  

  

For an explanation on Master DOFs, see the section on Using the Reduced Method for 
modal analysis.  

3. Constrain the Beam 
Solution Menu > Define Loads > Apply > Structural > Displacement > On nodes 

Fix the left most node (constrain all DOFs). 

4. Apply Loads 

We will define our impulse load using Load Steps. The following time history curve shows our 
load steps and time steps. Note that for the reduced method, a constant time step is required 
throughout the time range.  

  

We can define each load step (load and time at the end of load segment) and save them in a file 
for future solution purposes. This is highly recommended especially when we have many load 
steps and we wish to re-run our solution.  

We can also solve for each load step after we define it. We will go ahead and save each load step 
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in a file for later use, at the same time solve for each load step after we are done defining it.  

a. Load Step 1 - Initial Conditions 

i. Define Load Step 

We need to establish initial conditions (the condition at Time = 0). Since the 
equations for a transient dynamic analysis are of second order, two sets of initial 
conditions are required; initial displacement and initial velocity. However, both 
default to zero. Therefore, for this example we can skip this step.  

ii. Specify Time and Time Step Options 

Select Solution > Load Step Opts > Time/Frequenc > Time - Time Step .. 
set a time of 0 for the end of the load step (as shown below).  
set [DELTIM] to 0.001. This will specify a time step size of 0.001 
seconds to be used for this load step.  

  

iii. Write Load Step File 

Select Solution > Load Step Opts > Write LS File 

The following window will appear 
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Enter LSNUM = 1 as shown above and click 'OK' 

The load step will be saved in a file jobname.s01  

b. Load Step 2 

i. Define Load Step 

Select Solution > Define Loads > Apply > Structural > Force/Moment > On 
Nodes and select the right most node (at x=1). Enter a force in the FY direction 
of value -100 N.  

ii. Specify Time and Time Step Options 

Select Solution > Load Step Opts > Time/Frequenc > Time - Time Step .. 
and set a time of 0.001 for the end of the load step  

iii. Write Load Step File 
Solution > Load Step Opts > Write LS File 

Enter LSNUM = 2 

c. Load Step 3 

i. Define Load Step 

Select Solution > Define Loads > Delete > Structural > Force/Moment > 
On Nodes and delete the load at x=1.  

ii. Specify Time and Time Step Options 

Select Solution > Load Step Opts > Time/Frequenc > Time - Time Step .. 
and set a time of 1 for the end of the load step  

iii. Write Load Step File 
Solution > Load Step Opts > Write LS File 

Enter LSNUM = 3
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5. Solve the System 

Select Solution > Solve > From LS Files 

The following window will appear.  

  

Complete the window as shown above to solve using LS files 1 to 3.  

Postprocessing: Viewing the Results  
To view the response of node 2 (UY) with time we must use the TimeHist PostProcessor (POST26).  

1. Define Variables 

In here we have to define variables that we want to see plotted. By default, Variable 1 is assigned 
either Time or Frequency. In our case it is assigned Frequency. We want to see the displacement 
UY at the node at x=1, which is node #2. (To get a list of nodes and their attributes, select Utility 
Menu > List > nodes).  

Select TimeHist Postpro > Variable Viewer... and the following window should pop up. 
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Select Add (the green '+' sign in the upper left corner) from this window and the following 
window should appear 

  

We are interested in the Nodal Solution > DOF Solution > Y-Component of 
displacement. Click OK. 
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Graphically select node 2 when prompted and click OK. The 'Time History Variables' 
window should now look as follows 

  

2. List Stored Variables 

In the 'Time History Variables' window click the 'List' button, 3 buttons to the left of 'Add' 

The following window will appear listing the data:  

  

3. Plot UY vs. frequency 

In the 'Time History Variables' window click the 'Plot' button, 2 buttons to the left of 'Add' 
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The following graph should be plotted in the main ANSYS window.  

  

A few things to note in the response curve  

There are approximately 8 cycles in one second. This is the first mode of the 
cantilever beam and we have been able to capture it. 

We also see another response at a higher frequency. We may have captured some 
response at the second mode at 52 Hz of the beam. 

Note that the response does not decay as it should not. We did not specify damping 
for our system.  

Expand the Solution  

For most problems, one need not go further than Reviewing the Reduced Results as the response 
of the structure is of utmost interest in transient dynamic analysis.  

However, if stresses and forces are of interest, we would have to expand the reduced solution.  

Let's say we are interested in the beam's behaviour at peak responses. We should then expand a 
few or all solutions around one peak (or dip). We will expand 10 solutions within the range of 
0.08 and 0.11 seconds.  

1. Expand the solution 

Select Finish in the ANSYS Main Menu
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Select Solution > Analysis Type > ExpansionPass... and switch it to ON in the window 
that pops open. 

Select Solution > Load Step Opts > ExpansionPass > Single Expand > Range of Solu's 

Complete the window as shown below. This will expand 10 solutions withing the range of 
0.08 and 0.11 seconds 

  

2. Solve the System 
Solution > Solve > Current LS 
SOLVE 

3. Review the results in POST1 

Review the results using either General Postprocessing (POST1) or TimeHist 
Postprocessing (POST26). For this case, we can view the deformed shape at each of the 10 
solutions we expanded.  

Damped Response of the Cantilever Beam  

We did not specify damping in our transient analysis of the beam. We specify damping at the same time 
we specify our time & time steps for each load step.  

We will now re-run our transient analysis, but now we will consider damping. Here is where the use of 
load step files comes in handy. We can easily change a few values in these files and re-run our whole 
solution from these load case files.  

Open up the first load step file (Dynamic.s01) for editing Utility Menu > File > List > Other > 
Dynamic.s01. The file should look like the following.. 

/COM,ANSYS RELEASE  5.7.1  UP20010418       14:44:02    08/20/2001 
/NOPR 
/TITLE, Dynamic Analysis                                                       
_LSNUM=   1 
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ANTYPE, 4 
TRNOPT,REDU,,DAMP 
BFUNIF,TEMP,_TINY 
DELTIM, 1.000000000E-03 
TIME,  0.00000000 
TREF,  0.00000000 
ALPHAD,  0.00000000 
BETAD,  0.00000000 
DMPRAT,  0.00000000 
TINTP,R5.0, 5.000000000E-03,,, 
TINTP,R5.0, -1.00000000    , 0.500000000    , -1.00000000 
NCNV,     1,  0.00000000    ,     0,  0.00000000    ,  0.00000000 
ERESX,DEFA 
ACEL,  0.00000000    ,  0.00000000    ,  0.00000000 
OMEGA,  0.00000000    ,  0.00000000    ,  0.00000000    ,     0 
DOMEGA,  0.00000000    ,  0.00000000    ,  0.00000000 
CGLOC,  0.00000000    ,  0.00000000    ,  0.00000000 
CGOMEGA,  0.00000000    ,  0.00000000    ,  0.00000000 
DCGOMG,  0.00000000    ,  0.00000000    ,  0.00000000 
 
D,      1,UX  ,  0.00000000    ,  0.00000000     
D,      1,UY  ,  0.00000000    ,  0.00000000     
D,      1,ROTZ,  0.00000000    ,  0.00000000     
/GOPR 

Change the damping value BETAD from 0 to 0.01 in all three load step files. 

We will have to re-run the job for the new load step files. Select Utility Menu > file > Clear and 
Start New. 

Repeat the steps shown above up to the point where we select MDOFs. After selecting MDOFs, 
simply go to Solution > (-Solve-) From LS files ... and in the window that opens up select files 
from 1 to 3 in steps of 1. 

After the results have been calculated, plot up the response at node 2 in POST26. The damped 
response should look like the following 
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Command File Mode of Solution  
The above example was solved using the Graphical User Interface (or GUI) of ANSYS. This problem 
has also been solved using the ANSYS command language interface that you may want to browse. Open 
the file and save it to your computer. Now go to 'File > Read input from...' and select the file. 
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